Static Routing
Static Routing Between Two Routers Using Cisco Packet Tracer
By: Douglas Fessler
Objective
This lab demonstrates configuring static routing between two routers using Cisco Packet Tracer. The goal is to establish connectivity between devices in different subnets by manually adding static routes. This is a foundational skill for small networks where dynamic routing protocols are not necessary.
Tools Used
Software: Cisco Packet Tracer
Devices:
Two Cisco 2811 routers
Two PCs (one connected to each router)
Connections: Crossover Ethernet cables
Configurations: Static routing
Network Topology
· Router 1 (R1):
Interface GigabitEthernet0/1: IP 192.168.1.1/24
Interface GigabitEthernet0/0: IP 10.0.0.1/30
Connected PC: IP 192.168.1.2/24
· Router 2 (R2):
Interface GigabitEthernet0/1: IP 192.168.2.1/24
Interface GigabitEthernet0/0: IP 10..0.0.2/30
Connected PC: IP 192.168.2.2/24
Configuration Steps
Here’s how I configured the routers step-by-step:
Assign IP Addresses to Router Interfaces
o On Router 1:
R1> enable
R1# configure terminal
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface FastEthernet0/1
R1(config-if)# ip address 10.0.0.1 255.255.255.252
R1(config-if)# no shutdown
o On Router 2:
R2> enable
R2# configure terminal
R2(config)# interface FastEthernet0/0
R2(config-if)# ip address 192.168.2.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface FastEthernet0/1
R2(config-if)# ip address 10.0.0.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# no shutdown
Configure Static Routes
· On Router 1:
R1(config)# ip route 192.168.2.0 255.255.255.0 10.0.0.2
· On Router 2:
R2(config)# ip route 192.168.1.0 255.255.255.0 10.0.0.1
Verify Connectivity
Use the ping command to test connectivity between the PCs.
Results
After completing the configurations, I verified the connectivity by pinging from PC1 (192.168.1.2) to PC2 (192.168.2.2). The pings were successful, indicating the static routes were configured correctly.
Challenges and Solutions
During the lab, I encountered a minor issue where the router interfaces were initially down. I resolved this by ensuring the no shutdown command was applied to all interfaces.
Real-World Applications
Static routing is commonly used in small networks where simplicity is preferred over dynamic routing protocols. This lab demonstrates the ability to configure and troubleshoot static routes—a critical skill for network administrators managing small office or branch networks.
Reflection
This exercise reinforced my understanding of IP addressing and static routing. It also improved my troubleshooting skills, particularly in ensuring interfaces are active and configured correctly before verifying connectivity.